LAST REVISED: 02/04/14 23:04
CPC VIEW
USER'S GUIDE
VERSION 6.5

In the documentation below, advanced topics are described in this smaller font size.


1. General

CPC View implements a viewer for documents in a variety of file formats including TIFF and Cartesian's own CPC format. CPC View extends the capabilities of your web browser (e.g., Internet Explorer; Firefox), allowing it to directly display documents in any of the supported file formats. Once the viewer is installed, documents in these formats are displayed directly within the web browser along with a set of controls that allow navigation through and scaling of the images.

CPC View is distributed in two distinct variants:

To the end user, the usage of the two variants is identical. They differ only in their installation and uninstallation procedures.

For the purposes of this document, we will refer to CPC View when describing functionality common to all variants of the viewer, and the variant-specific name (e.g., CPC View ax) when describing functionality specific to a particular variant.


1.1. Supported Formats

CPC View supports images with up to 32,767 pixels in either dimension. Documents in the following formats are supported:

Format Mime type Typical extensions As of version
CPC image/cpi .cpi, .cpc 1.0
TIFF image/tiff .tiff, .tif b/w 1.0; color/gray 4.3.0
Portable Bitmap image/pbm .pbm, .pgm, .ppm, .pnm 1.0
JEDMICS C4 image/c4 .c4, .ct4 4.3.0
CALS image/cals .cals, .cal 4.3.0
JFAX documents application/tiff .jfx, .jfax 4.3.0


1.2. Installation

CPC View is compatible with all versions of Windows from Windows 95 to Windows 8. The procedure for installing CPC View depends on the variant (CPC View ax or CPC View pi) that you are installing.

1.2.1. CPC View ax

To install CPC View ax, simply download the CPC View ax Installer and double-click on the downloaded file (CpcViewAX.msi):

Note: 64-bit versions of Windows include both a 32-bit version of Internet Explorer and a 64-bit version of Internet Explorer. When the user launches Internet Explorer, Windows uses the 32-bit version. CPC View ax is only compatible with the 32-bit version of Internet Explorer. It can not be used with the 64-bit version of Internet Explorer.

Installation via Internet Explorer

CPC View ax can also be installed using the automatic control installation capability of Internet Explorer. This capability allows CPC View ax to be installed by simply visiting a web page:


Manual Installation

You can also manually install the CPC View ax control, as follows:

  1. If you have not already done so, download the latest version of the CPC View ax OCX file and save it on your computer.

  2. Click the Start button on the Windows task bar. This will cause the Windows Start menu to appear.

  3. Select the Run... command from the Windows Start menu. This will cause the Run window to appear.

  4. Enter the following text into the Run window:
    regsvr32 "<path-to-ocx-file>"
    where <path-to-ocx-file> is replaced with the full pathname of the OCX file that you downloaded. For example, if you saved the CPC View ax control to c:\Program Files\Cartesian Products\CpcViewAX.ocx, the following command would register the control:
    regsvr32 "c:\Program Files\Cartesian Products\CpcViewAX.ocx"
That should do it. The control should now be installed. To test the installation of the control, try opening this document.

Warning: Once the control has been manually installed, the CpcViewAX.ocx file should not be moved. If you do move the file, you must re-install the control.

1.2.2. CPC View pi

Installation dialog box To install CPC View pi, you will need the CPC View pi installation program. If you do not have the installation program, you can download it from our web site.

Once you have retrieved the installation program, follow these simple instructions:



Installation location

CPC View pi is installed within the installation folder of your web browser (e.g., Firefox). The CPC View pi installation program will investigate your system and attempt to select your default web browser as the installation location. If you wish to change the installation location, click on the "Change" button. This will cause the "Locate Browser" dialog to appear. Use the "Locate Browser" dialog to select the location of the web browser application into which you wish to install CPC View pi.

By default, the Firefox browser is located at:

C:\Program Files\Mozilla Firefox\Firefox.exe


1.3. Opening Documents

To display a document in CPC View, simply open the document in your web browser (e.g., Internet Explorer; Firefox). Your web browser will then automatically load CPC View to display the document.

For example, if you have CPC View installed, you can display an image in CPC View by clicking here.

1.3.1. Opening Local Files

Your web browser can also be used to open image documents stored locally on your computer's hard disk. There are several ways to open a local image document in your web browser:


1.4. Uninstallation

The procedure for removing CPC View depends on the variant (CPC View ax, CPC View pi, or CPC Lite pi) that you are removing.

1.4.1. CPC View ax

CPC View ax can be uninstalled using the Add/Remove Programs facility of the Windows Control Panel. The following procedure can be used to uninstall CPC View ax:
  1. Start the Windows Control Panel application. On most systems, this can be done by selecting "Control Panel" from the Windows Start menu.
  2. Click on "Add or Remove Programs" in the "Control Panel" window. This will bring up the "Add or Remove Programs" window.
  3. The window should contain a list of installed programs on your system. Select the item titled "CPC View ax" and click on the "Remove" button. This will start the CPC View ax Uninstaller.

Removal via Internet Explorer

If you installed CPC View ax using the automatic control installation capability of Internet Explorer, you can also use Internet Explorer to uninstall the control. The following procedure can be used to uninstall CPC View ax:
  1. Select the "Internet Options" command from the Internet Explorer "Tools" (or "View") menu. This will bring up the "Internet Options" window.
  2. Select the "General" tab at the top of the "Internet Options" window.
  3. Click the "Settings..." button in the "Temporary Internet Files" or "Browsing History" section. This will bring up the "Settings" window.
  4. Click the "View Objects..." button. This will open the "Downloaded Program Files" window.
  5. The "Downloaded Program Files" folder will contain an entry labeled "CPC View ax Control". Select this entry and click with the right mouse button. This will cause a menu to appear.
  6. Select "Remove" from the menu. This will remove CPC View ax.

Manual Removal

If you manually installed CPC View ax (using the regsvr32 utility), you must also use the regsvr32 utility to uninstall the control. For example, if the control is installed at c:\Program Files\Cartesian Products\CpcViewAX.ocx, the following command would uninstall the control:

  regsvr32 /u "c:\Program Files\Cartesian Products\CpcViewAX.ocx"

Once the control has been uninstalled, you can delete the CpcViewAX.ocx file.

1.4.2. CPC View pi

Uninstallation dialog box CPC View pi (v5.1 or later) can be uninstalled via the Add/Remove Programs facility of the Windows Control Panel. The following procedure can be used to uninstall CPC View pi:
  1. Start the Windows Control Panel application. On most systems, this can be done by selecting "Control Panel" from the Windows Start menu.
  2. Click on "Add or Remove Programs" in the "Control Panel" window. This will bring up the "Add or Remove Programs" window.
  3. The window should contain a list of installed programs on your system. Select the item titled "CPC View ax" and click on the "Remove" button. This will start the CPC View pi Uninstaller.
  4. The Uinstaller window will contain a list of the locations in which CPC View pi is installed on the system. Select the locations that you wish to uninstall and click the "Uninstall" button at the bottom of the window.
  5. A dialog box will appear requesting confirmation of the uninstall operation. Click on the "Yes" button to continue the uninstall.
  6. A dialog box will appear informing you that the uninstall has completed. Click on the "OK" button to dismiss the dialog box.
  7. Restart your Web browser.

Manual Removal

Versions of CPC View pi earlier than V5.1 must be uninstalled manually. The installation of CPC View pi comprises a single file, NPCPC32.dll, which is installed in the "plugins" folder of your web browser installation. To manually uninstall CPC View pi, delete the file NPCPC32.dll and restart your browser.

The "plugins" folder is located in the same folder as your web browser executable. If you are unsure of the location of this folder, you can use the "Find/Files or Folders..." command in the Windows "Start" menu to locate the file NPCPC32.dll.

1.4.3. CPC Lite pi

Uninstallation dialog box CPC Lite pi (v5.1 or later) can be uninstalled via the Add/Remove Programs facility of the Windows Control Panel. The following procedure can be used to uninstall CPC Lite pi:
  1. Select "Control Panel" from the "Settings" sub-menu of the Windows Start menu. This will start the Windows Control Panel application.
  2. Double-click on "Add/Remove Programs" in the "Control Panel" window. This will bring up the "Add/Remove Programs Properties" dialog box.
  3. Select the "Install/Uninstall" tab at the top of the dialog box.
  4. The dialog box should contain a list of installed programs on your system. Select the item titled "CPC Lite Plugin" and click on the "Add/Remove..." button. This will bring up the CPC Lite pi Uninstaller.
  5. The Uinstaller window will contain a list of the locations in which CPC Lite pi is installed on the system. Select the locations that you wish to uninstall and click the "Uninstall" button at the bottom of the window.
  6. A dialog box will appear requesting confirmation of the uninstall operation. Click on the "Yes" button to continue the uninstall.
  7. A dialog box will appear informing you that the uninstall has completed. Click on the "OK" button to dismiss the dialog box.
  8. Restart your Web browser.

Manual Removal

Versions of CPC Lite pi earlier than V5.1 must be uninstalled manually. The installation of CPC Lite pi comprises a single file, NPCPC32.dll, which is installed in the "plugins" folder of your web browser installation. To manually uninstall CPC Lite pi, delete the file NPCPC32.dll and restart your browser.

The "plugins" folder is located in the same folder as your web browser executable. If you are unsure of the location of this folder, you can use the "Find/Files or Folders..." command in the Windows "Start" menu to locate the file NPCPC32.dll.


2. The Toolbar

Once the viewer is running, the CPC toolbar provides status information about the currently displayed document, as well as providing access to the most commonly used functions of the viewer. The following sections describe the functionality of the toolbar.


2.1. Views

Documents may be viewed in a page view in which only a single page is shown at a time or a thumbnail view in which all pages are shown as small thumbnails.

By default, the document is brought up in page view. You can move to the thumbnail view by selecting the right "thumbnail" button in the "View" control or double-clicking on the image. You can return to page view from thumbnail view by selecting the left "page" button in the "View" control or double-clicking on the thumbnail representing the page to move to.

While in thumbnail view, you can use the mouse to select multiple pages within the document. This can be helpful when printing or saving a subset of the pages within the document. When you invoke the Print or Save commands from thumbnail view with multiple pages selected, the command dialog box defaults to a page range containing only the selected pages.

You can control which pages are selected as follows:

The view selection functionality is also available through a menu on the right mouse button within the viewer. The View sub-menu contains a "Properties..." command that displays any properties of the document, such as resolution, image size, and document source that may be stored with the image.


2.2. Navigating Among Pages

In addition to selecting pages in the thumbnail view, you can navigate among pages in a multi-page document using the "Page" control. The left and right arrow buttons within the control move backward and forward one page, respectively. The current page number is always shown in the text box in the "Page" control. Clicking on this number with the left mouse button pops-up a menu of all page numbers, from which a new page can be selected. Clicking on this number with the right mouse button pops-up a window into which you can enter a specific page number.

Use the back and forward buttons to navigate among the history of pages within the document that you have viewed. Similar to the back and forward buttons on a web browser, the back button takes you back to the previously viewed page and the forward button moves you forward to the next viewed page.

You can also navigate through the pages of the document using the left and right arrow keys on the keyboard.

The page selection functionality is also available through a menu on the right mouse button within the viewer.

If the document contains only a single page, the page navigation functions are disabled.


2.3. Scrolling Pages

Often pages of the document will be larger than the viewer's window. In such cases, the scroll bars at right and bottom can be used to scroll around in the page image. In general, all scaling and scrolling changes persist as you move from page to page.

The "Mouse" control, pictured at left, determines the current mouse mode that the viewer is in. By default, the viewer is in "scroll" mode, as indicated by the hand button being depressed. (The magnifying glass button puts the viewer in "zoom" mode; the pencil button puts the viewer in "annotation" mode.) When in scroll mode, the mouse can be used to "grab" a point on the image and drag it around on the screen.

In addition, the "Scrollpad" control, which looks like a yellow rectangle on a white page background, can be used for scrolling. The yellow rectangle depicts the position of the viewer window on the page image. By dragging the yellow rectangle around, the viewer window can be moved over the page.


2.4. Scaling Pages and Thumbnails

The "Zoom" control allows scaling of the pages in both page and thumbnail view. In general, all scaling and scrolling changes persist as you move from page to page.

The scaling functionality is also available through a menu on the right mouse button within the viewer.

2.4.1. Scaling in Page View

In page view, the up and down arrows double and halve the scale respectively. The current scale is shown as a percentage of full resolution in the text box in the "Zoom" control. Clicking on this number with the left mouse button pops-up a menu of scale factors, from which a new scale can be selected. Clicking on this number with the right mouse button pops-up a window into which you can enter a specific scale factor.

The horizontal double arrow and vertical double arrow buttons force a scale factor that fits the current page to fit within the width or height, respectively, of the viewer window.

2.4.2. Scaling in Thumbnail View

In thumbnail view, the up and down arrows increase or decrease the number of images per row or column by one. The current scale is shown as a percentage of full resolution. Clicking on this number pops-up a menu from which a new number of thumbnails per row or column may be selected.

If the horizontal double arrow button is selected, the arrows and current scale pop-up govern the number of images per row. If the vertical double arrow button is selected, the arrows and current scale govern the number of images per column.

2.4.3. Zooming

Zooming in on a particular region can also be done by dragging the region when in "zoom" mode. The magnifying glass button in the "Mouse" control puts the viewer into zoom mode. (The hand button returns the viewer to "scroll" mode; the pencil button puts the viewer in "annotation" mode.) When in "zoom" mode, you can drag the left-mouse button to select the region to zoom to. When you release the left mouse button, the selected region will be scaled to fill the window. This works in both page view and thumbnail view. (If you are in thumbnail view, the viewer will switch to page view when you release the mouse button.)

The zoom operation may be cancelled by clicking on the right mouse button prior to releasing the left mouse button, which switches back to "scroll" mode. There is also an "Undo last zoom" operation available from the right mouse menu, which allows undoing the sequence of zoom operations that have been executed since the document was opened.

Scaling factors for the fit-to-width options and so forth are generally chosen to maximize image quality, rather than exactly fill the screen. Selecting "Enable Precision Zoom" option from the Zoom sub-menu of the right mouse menu causes the viewer to allow scalings that exactly fill the screen, at some cost in image quality and rendering speed. This option is generally not recommended but is incorporated for special applications.

This option is only available when displaying black-and-white documents; precision zooming is not supported on grayscale and color documents.


2.5. Rotating Pages

Page images can be rotated at 90-degree increments using the "Rotation" control. The control shows four faces representing the four 90-degree rotations available. Clicking on each causes all page images in the current document to be displayed at that rotation.


2.6. Setting Foreground and Background Colors

You can set the foreground and background colors used when rendering black-and-white or gray-scale pages using the "Color" control. The control has two buttons that show the current color choices for foreground (default black) and background (default white). Clicking on either button brings up a color selection dialog box that allows you to choose alternative colors. Clicking on the arrow line below the two buttons causes the foreground and background colors to be swapped, inverting the colors of the image. Clicking again swaps them back.

By default, the "Color" control is not provided in the toolbar. You can add it to the toolbar using the toolbar configuration methods described below.


2.7. Status Information

The title bar, which takes up the remaining space in the toolbar of controls, often provides information on the status of the document. A pie chart indicates progress in decompressing images in preparation for viewing. A moving pencil indicates that the page is still being rendered on the screen. The name of the document is also displayed in this area.


2.8. Configuring

You can completely configure which controls appear in the toolbar and in what order. Clicking the right mouse button in the toolbar brings up a "Configure Toolbar" window that allows you to select which controls you want to appear in the toolbar and where the toolbar should be located. Check off the boxes that you want to appear in the toolbar. The toolbar reflects your selections immediately. To restore the toolbar to its initial state when the software was installed, click on "Restore Factory Settings".

To change the default location of the toolbar, click on one of the bottom buttons in the "Configure Controls" dialog box. By default, the toolbar is at the top, but you can select left, right, or bottom as well.

You can get rid of the toolbar completely by selecting the option "none" from the "Toolbar" submenu of the right mouse menu.

To change the order in which the various controls appear in the toolbar, you can drag the controls around with the left mouse button by mousing down on a point in the control that is not otherwise mouse-sensitive. (The mini-title-bar of the control is a natural place to use.) Alternatively, you can hold down the "Alt" key and mouse down anywhere in the control to drag the control. (Prior to Version 4.2 of CPC View, dragging controls required use of the "Alt" key.) The controls snap into place as you drag them past other controls. The figure at right shows the screen as the user is moving the "Rotation" control to the right.

All configuration changes are preserved so that the next time you run the viewer, the toolbar will be set up just the way you like it.


3. Right Mouse Menu

In addition to the CPC toolbar, you can also use the CPC right mouse menu (pictured at right) to access the functionality of the viewer. To access the right mouse menu, just click the right mouse button anywhere within the image area of the viewer. This will cause the right mouse menu to appear.

The different sections of the menu provide the same functionality as the "Page" control, the "Zoom" control, the "View" control, the "Rotation" control, the "Color" control, the Toolbar Position control, and the Mouse control. The Document sub-menu contains commands to save the current document to a file (optionally converting it to a different file format), to email the current document, and to print the current document.

The right mouse menu also provides access to functionality that is not available via the CPC toolbar.


3.1. Help

Access current documentation on CPC View with the "Help..." menu item, which will open up a new browser window with the on-line documentation for CPC View.


3.2. About CPC View

Find out about your version of CPC View, including the license that you are working under, with the "About CPC View..." or "About CPC Lite..." menu item.

The About CPC window is displayed to the right. Several of the items in the window are hyper-linked:



4. Annotations

CPC View includes the ability for users to annotate documents with text, graphics, and sound, and to view and email documents annotated in this way.


4.1. Viewing Annotations

As a viewer, CPC View works essentially identically whether the viewed document contains annotations or not. The only differences when viewing an annotated document are the following:

The annotations themselves - Annotations will be shown overlayed on the images regardless of magnification and in both page and thumbnail views.

Annotation count - The title bar of the document (see sample at right) will show a count of the number of annotations on the current page, e.g., 2 Annotations.

Annotation check box - A check box next to the annotation count allows you to hide all the annotations.

Underlying image - If the document consists of annotations overlayed on a separate image file, the URL of the underlying image file is given next to a paper clip icon (). Clicking on the paper clip causes the browser to a open a new window viewing this underlying image file.

Status line - Placing the mouse cursor over an annotation highlights the annotation and may cause the status line at the bottom of the browser to display a "tip message" (as depicted at right).

4.1.1. Pop-ups, Sound, and Hyperlinks

CapabilityIcon
Text pop-up
Sound attachment
Hyperlink
Annotations may have text or sound attachments or may act as hyperlinks. Annotations that have these associated capabilities are marked with special icons, as shown in the table at right.

The figure at left shows an annotation with associated text pop-up, sound attachment, and hyperlink. To view the attachments or access the hyperlink, you would simply click on the annotation.

4.1.2. Pure Hyperlinking

When an annotation has an associated hyperlink and does not contain a text or sound attachment, clicking on the annotation will cause the browser to go to the destination hyperlink.

4.1.3. The Annotation Inspector

Clicking on an annotation will pop up an "annotation inspector", which displays information about the annotation. A sample annotation inspector for the annotation above is shown at right.

If the annotation has a hyperlink, and it does not have sound or pop-up text, clicking on the annotation will follow the hyperlink. To display the annotation inspector for such an annotation, click the annotation with the right mouse button.

The annotation inspector, like all of the inspector dialog boxes in CPC View, has a simple internal help facility. The line at the bottom of the annotation inspector provides a "tip" describing the content or function of whatever part of the inspector the mouse is over.

The annotation inspector displays the date and time that the annotation was created and the name of the person who added the annotation. (To change the name associated with your annotations use the View/Preferences... command in the right mouse menu.)



4.2. Authoring Annotations

You must enter Annotation Mode to compose new annotations. (You can view annotations in any mode.) To enter Annotation Mode, click on the pencil button in the "Mouse" control section of the toolbar. (Or, use the "Mouse/Annotate" option on the right mouse menu.)

4.2.1. The Annotation Storage Folder

The very first time you enter Annotation Mode, CPC View will prompt you for the local folder in which to automatically and transparently store annotations that you make to documents. Select a folder. Once you have selected a folder, CPC View will remember it, and you will not be asked again. To change the folder for automatic annotation storage, use the View/Preferences option in the right mouse menu.

4.2.2. Selecting Annotations

To select an annotation, click the left mouse button on it. A red border with blue control points will appear around the annotations bounding box.

To resize a selected annotation, drag the blue control points.

To move a selected annotation, drag starting within the bounding box itself.

To edit a text annotation,double-click on the annotation.

4.2.3. The Annotation Toolbar

While you are in Annotation Mode, a new toolbar appears at the bottom of the window.

The controls in the annotation toolbar can be reconfigured, just like the controls in the main toolbar.

The Palette Controls

The left-most group of controls, labeled "Palette", contains a variety of drawing tools. To add an annotation, select one of the tools in the palette by clicking on it with the left button. You can then add annotations to the image by dragging the mouse over the document.

The Clipboard

To the right of the "Edit" group is the clipboard. Annotations can be moved to the clipboard by cutting or copying them. Whenever an annotation is on the Windows clipboard, a small small rendering of it is displayed over the Clipboard icon. To paste the annotation, click on the clipboard or use the "Insert" menu item on the right mouse menu.

Clicking on the small book icon to the right of the clipboard pops up a list of annotations that have recently been placed on the clipboard. You can click on them to insert them onto the current page.

The Edit Controls

The center group of controls, labeled "Edit", contains buttons to cut, delete, and copy annotations. Additionally, the CPC View annotation editor maintains a complete undo/redo list of all changes to the document during the current session. The counter-clockwise arrow will undo the most recent change; the clockwise arrow will redo the most recent change that was undone. Clicking repeatedly on the undo button will undo more and more of the changes.

To delete all of the annotations on the current page, click the right mouse button anywhere on the background image and select Delete All from the menu that appears.

The Save Controls

In general, CPC View will automatically save your annotations to files in the Annotation Folder you selected. The files are saved such that the next time you view the same URL, the annotations will be automatically loaded. While CPC View is in its automatic save mode, the text in the "Save" group will display "<automatic>".

You can also save annotations explicitly. Click on the button to the right of the text (or the text itself) to select a file in which to save the annotations. Explicitly saved annotations are not reloaded automatically when you revisit the same URL. Rather, if you open the saved annotation file, CPC View will automatically load the original URL and display the annotations over it.

When you view annotations in a saved annotation file, the text in the "Save" group will display the name of the file. If you modify the annotations, the left "Save" button will be enabled. This button allows you to save the annotations back to the file.

If the annotations for the document come from a remote Annotation Server, the text in the "Save" group will display "<remote>". If you modify the annotations, the left "Save" button will be enabled. This button allows you to save the annotations back to the remote server.

If your machine has MAPI installed (for instance, if you run Microsoft Exchange), there will be an email button in the save group. Use this button to email annotated documents.

Note: The image document itself is converted to CPC format and included in the email attachment. If the source image document is not already in CPC format, this operation requires a conversion battery.

Adding new palette items

You can make any annotation into a new palette item by clicking the right mouse button on the annotation and selecting the "Edit/Add to Palette" option on the right mouse menu. This will place a miniature copy of the annotation in the palette, which acts as a new palette tool for adding copies of this annotation. For instance, you might add a new tool for placing the text "Approved" in large red letters.

Added palette items are persistent; they stay available from one session to the next.

4.2.4. Annotation Properties

There are five basic types of annotations:

Each type has associated with it a variety of general and specific properties. To change the properties associated with an annotation, click on the annotation with the right mouse button to display a menu of commands. The "Properties..." command pops up an inspector dialog box that allows you to edit the various properties of the annotation.

For non-text annotations, you can also access the inspector by double-clicking on the annotation.

You can also use the right mouse menu on the palette buttons to change the properties of the palette tools themselves.

General annotation properties

All of the inspectors allow control of properties of the "paper" on which the annotation is drawn, that is, the background of the bounding box of the annotation. The color and transparency of the paper can be controlled, as well as the type of border (shadow, inset, embossed, none).

In addition, all allow control of the actions associated with the annotation, that is, text pop-up, sound attachments, hyperlinks, and status line messages. These are controlled with a set of four tab items at the bottom of the inspector dialog.

The text action tab item allows you to edit the text that will be popped up in the annotation inspector when the annotation is clicked on.

Clicking on the small book icon to the right of the text area pops up a list of previously used pop-up text items. You can click on them to insert them.

The hyperlink action tab item allows you to add the URL of the hyperlink destination for this annotation.

A convenient way to generate this URL when the destination is a document viewable by CPC View (perhaps a different page of the current document) is to use the "Document/Copy URL" option from the right mouse menu. This copies the current URL so that it can be pasted into the URL area; a "Paste" option will be in the right mouse menu when the cursor is in the URL area.

Clicking on the small book icon to the right of the URL area pops up a list of previously used destination URLs. You can click on them to insert them.

The sound action tab item contains controls as for a tape recorder, for recording and playback of the sound attachment.

The tip action tab item allows you to add text to be displayed as a tip on the browser's status line when the mouse is over this annotation. (By default, the tip used contains the date, time, and author of the annotation, as shown above.

Clicking on the small book icon to the right of the text area pops up a list of previously used tip messages. You can click on them to insert them.

Text annotation properties

The "Properties" menu item for a text annotation pops up the "text inspector" (depicted at right), which allows you to control the font, size, color, and style of the text. In addition,

Box annotation properties

The "Properties" menu item for a box annotation pops up the "box inspector" (depicted at right). The actions and paper properties can be controlled as described above.

Circle annotation properties

The "Properties" menu item for a circle annotation pops up the "circle inspector" (depicted at right), which allows you to control the colors of the circle interior and border. In addition, the actions and paper properties can be controlled as described above.

Line annotation properties

The "Properties" menu item for a line annotation pops up the "line inspector" (depicted at right), which allows you to control the line thickness and color, the addition of arrowheads at either end of the line, and the relation of the line to the annotations bounding box (single diagonal, both diagonals, horizontal, or vertical). In addition, the actions and paper properties can be controlled as described above.

Freehand annotation properties

The "Properties" menu item for a freehand line annotation pops up the "freehand inspector" (depicted at right), which allows you to control the line thickness and color. In addition, the actions and paper properties can be controlled as described above.


5. Printing Documents

To print a document, click the printer button on the CPC toolbar. Or, choose Print... from the Document sub-menu of the right mouse menu.

If the printer button is not present on the CPC toolbar, you can add it to the toolbar using the toolbar configuration methods described below.

Warning: Because of limitations in Microsoft Internet Explorer, CPC View cannot support printing invoked via Internet Explorer's toolbar or "File" menu. Under Internet Explorer, you must use the CPC toolbar button or right mouse menu to invoke printing.

Invoking the print command will bring up the dialog box depicted to the right. (Click on the figure for a full-size version.) Use the dialog box to select the printer and other options. Standard Windows controls allow selection of: the printer, the range of pages to print, the number of copies to print and collation preferences. Several additional CPC-specific options are described in more detail below. Once the appropriate options are selected, click the Print button to initiate printing.


5.1. Print range

The Print range options select the range of pages to print:


5.2. Copies

The Copies options determine the number of copies to print, collation of copies, and odd/even printing:


5.3. Auto-scale

The Auto-scale options determine the scaling of the pages when printed to the printer.

Note: The current zoom magnification on the screen does not affect the print scaling, except when using the current view option described above.



5.4. Options

This group of controls enables various printing features.


5.5. Inclusions

This group of controls enables various additional items that are printed on the page along with the image.


5.6. Remember Settings

If the "Remember settings" option is checked, the viewer will make the current settings the default settings for subsequent invocations of the print command. The default settings include the selected printer and printer properties, as well as the "Print range", "Auto-scale", "Options", and "Inclusions" settings.


5.7. Default Printer

The "Default Printer" button resets the printer to the system default printer and sets the printer properties to the system default properties.


6. Saving Documents

To save a document displayed by CPC View, click the save button on the CPC toolbar. Or, choose Save As... from the Document sub-menu of the right mouse menu.

If the save button is not present on the CPC toolbar, you can add it to the toolbar using the toolbar configuration methods described below.

Invoking the save command will bring up the dialog box depicted to the right. (Click on the figure for a full-size version.) Standard Windows controls allow selection of the file name, folder, and file format. CPC-specific controls are described in more detail below. Once the appropriate options are selected, click the Save button to initiate the save.



6.1. Save As Type

CPC View can save the document in a variety of different file formats. The Save as type drop-down menu is used to specify the particular file format desired.

The file formats available for a particular document depend on the color format of the document (black-and-white; gray-scale; color), as well as whether or not the document contains annotations.

6.1.1. Black-and-White Formats

Black-and-white images can be saved in any of the following file formats:

If the document has annotations, the following additional file formats are available:


6.1.2. Gray-Scale Images

Gray-scale images can be saved in any of the following file formats:

If the document has annotations, the following additional file formats are available:


6.1.3. Color Images

Color images can be saved in any of the following file formats:

If the document has annotations, the following additional file formats are available:


6.1.4. Original

All non-CPC source documents provide an Original "Save as type"; this type causes CPC View to save an exact copy of the original source file.

This type is equivalent to using your web browser's File/Save As... command (assuming your web browser supports this command for embedded documents).


6.2. Page Range

This group of controls is used to specify the pages of the source document to include in the saved file. To specify all of the pages in the source document, select the "All" option.

To specify a range of pages, select the "Range" option and enter the page ranges into the adjacent text box. Each page range is specified as either a single page (e.g., 5) or a contiguous range of pages (e.g., 3-7). Multiple ranges should be separated by commas or spaces (e.g., 1, 2, 4-6).

The end page of a contiguous range can be left empty. This is interpreted as a range that ends with the last page of the document. For example, the range 3- specifies all pages from the 3rd page on.

This set of controls is NOT available when the Save as type is set to either CPC Annotations (annotations only) or CPC Annotated Document. With these types, CPC View always includes all of the source pages in the saved document.


6.3. Conversion Batteries

If the source document is not in the CPC file format, the conversion of the source document to other file formats, such as CPC, requires the installation of a CPC conversion battery. The installation of the viewer includes a 1000 page conversion battery.

A battery is NOT required for conversion of CPC source documents; the viewer will freely convert CPC images to the TIFF, PDF, or PBM file formats.


7. Emailing Documents

To email the document displayed by CPC View, select the Email Document... command from the Document sub-menu of the right mouse menu.

Invoking the email command will bring up the dialog box depicted to the right. This dialog allows selection of the file format to use for the document attachment.

Once you have choosen the attachment format, click the OK button. This will cause a new message with the document attachment to be created in your email program.

Note: The ability to specify the file format of the attachment requires CPC View v6.4 or later. In earlier versions, the attachment is always created in the CPC file format.


8. The Contents Bar

If the document contains a table of contents, CPC View will display the Contents Bar at the top of the document window. The Contents Bar provides information about the currently displayed section of the document, as well as tools with which to navigate among the document's sections.

If the CPC toolbar is at the top of the document window, the Contents Bar will be displayed at the bottom of the document window.

Note: Requires CPC View version 6.4 or later.


8.1. Section Name

The name of the current section is always displayed in the center of the Contents Bar.



8.2. Next and Previous Section

The Contents Bar provides buttons to move to the next and previous sections in the document.


8.3. Page Range

The page range of the current section is always displayed on the right side of the Contents Bar.


9. Interacting with the Windows Clipboard

To copy the current view of the image to the Windows clipboard, select the Copy to Clipboard command from the View sub-menu of the right mouse menu. The image is copied to the clipboard exactly as it appears on the screen. If the image is scaled such that only a portion of the image is visible in the window, only that portion of the image is copied to the clipboard.

The command is available in both page view and thumbnail view. In thumbnail view, it copies the currently visible thumbnails to the clipboard.

The copy function can also be activated by typing 'c' while the image window has keyboard focus.


10. Keyboard Shortcuts

Keyboard shortcuts allow you to initiate viewer commands directly from the keyboard. Shortcuts are accessible whenever the viewer window has keyboard focus. The following shortcuts are available:
Key Description
p Print the document
s Save the document
Z Zoom in (increase the display magnification).
z Zoom out (decrease the display magnification).
g Goto page.
Space Display the next page
Backspace Display the previous page
c Copy the current view of the document to the Windows clipboard
b Go back to the previously viewed page
f Go forward to the next viewed page
 
Page Up Scroll up one screen
Page Down Scroll down one screen
Home Scroll to the top of the page
End Scroll to the bottom of the page
Left Arrow If the left edge of the image is not visible, scroll left one screen. Otherwise, move to the previous page.
Right Arrow If the right edge of the image is not visible, scroll right one screen. Otherwise, move to the next page.
Up Arrow If the top edge of the image is not visible, scroll up one screen. Otherwise, move to the previous page.
Down Arrow If the bottom edge of the image is not visible, scroll down one screen. Otherwise, move to the next page.


11. Preferences

Select the "View/Preferences" item from the right mouse menu to edit the CPC View preference settings.


11.1. User Interface Language

Use the language tabs at the top of the window to specify the user interface language. Click on the appropriate tab to select the language. The change to the user interface takes effect immediately.


11.2. General



11.3. Imaging



11.4. Annotations



11.5. TIFF Encoding

The TIFF file format allows for a variety of different image compression methods. This section allows you to specify the compression method to use when CPC View encodes TIFF images.


11.6. Sound Recording

This section controls the quality and size of annotation voice recordings.



12. Customization

CPC View supports certain customizable features through the Windows registry. These features are not directly accessible from the CPC View user interface. They are intended for use within third-party installation programs.


12.1. Specifying the Help URL

[This customization is supported in version 5.3.1 and later.]

The target URL for the Help... command (available from the CPC right mouse menu) can be specified in the registry. To specify the target URL, create a string value named Help within the following registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Cartesian Products\CPC View\URLs
Set the value of Help to the desired URL target for the Help... command.

For example, setting the Help value to "http://foobar.com" would cause CPC View to open "http://foobar.com" whenever the Help... command is invoked.

12.1.1. Additional help parameters

If the specified target URL contains a "?", CPC View will append two parameters to the URL when accessing the help page:

The following example regedit file specifies that the help page is at "http://localmirror.com/Help/help.cgi?which=cpcview".

REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\Cartesian Products\CPC View\URLs]
"Help"="http://localmirror.com/Help/help.cgi?which=cpcview"
Under version 5.3.1 (or later) of the plug-in, CPC View would access this help page using the URL "http://localmirror.com/Help/help.cgi?which=cpcview&version=5.3.1&architecture=plugin"

If you would like to change the Help target for the current user, rather than all users, edit the registry key HKEY_CURRENT_USER\Software\Cartesian Products\CPC View\URLs rather than HKEY_LOCAL_MACHINE\SOFTWARE\Cartesian Products\CPC View\URLs.

© 1998-2014 Cartesian Products, Inc. Contact Cartesian